Dashboard excel per l’analisi delle risorse umane: esempio di come monitorare alcune variabili legate al tema della gestione e valorizzazione delle risose umane. L’articolo rientra nella logica applicativa di excel e risorse umane.

Dashboard excel per l’analisi delle risorse umane. gestire e valorizzare le risorse umane tenendo sotto controllo competenze e skill professionali. Scopo di questo articolo è quello di proporre un esempio pratico di costruzione di un semplice dashboard con lo strumento excel per analizzare le risorse umane e i loro trend all’interno di un’azienda.

Il modello è stato semplificato e vuole semplicemente essere un esempio: indicatori, dati, grafici possono essere customizzati e completamente rielaborati, l’obiettivo è stato quello di evidenziare come sia necessario seguire precisi step per creare un modello dinamico e facilmente modificabile.

La gestione delle risorse umane, intese come perno centrale e patrimonio di un’azienda diventa efficace se attuata attraverso una politica di individuazione, monitoraggio e valorizzazione delle risorse umane. Sul tema delle competenze avevamo già dedicato un articolo dal titolo “Valutare le risorse umane attraverso competenze ed obiettivi da raggiungere”.

Oggi ci focalizzeremo su semplici analisi e statistiche del personale presente in una qualunque azienda Alfa (Trend, salari medi, assenze ecc).

 

Dashboard excel per l’analisi delle risorse umane: come costruire un modello step by step

Come detto, l’esempio riportato è molto semplicistico ma può essere esteso anche a popolazioni aziendali molto più estese e complesse. Sul mercato sono presenti diversi software di gestione del personale che possono fornire statistiche in pochi click, tuttavia il Responsabile RU che non ha un budget per un simile investimento, può ricorrere all’ausilio di Ms Excel , ottenere ottimi risultati e massimizzare le customizzazioni al modello.

Il file che trovate in allegato è composto dai seguenti fogli di lavoro

•    Database: dove sono state inserite tutte le informazioni del personale
•    Tabelle: dove sono state create delle tabelle riepilogative
•    Dashboard: dove è stato creato il cruscotto aziendale quale output finale grafico e numerico delle statistiche ritenute rilevanti ai fini statistici.

I nomi del personale utilizzato nell’esempio, i dati e i numeri sono puramente casuali; qui di seguito si riporta uno stralcio del database con i relativi campi utilizzati:

Nel modello sono stati individuati alcuni obiettivi di analisi riepilogabili qui di seguito:

1. Breakdown % del personale per divisione

2. Numero di risorse umane per dipartimento

3. Scheda di sintesi di una singola risorsa

4. Trend di crescita delle risorse umane presenti in azienda (Year over Year)

5. Distribuzione salariale

Il modello Excel implementato per monitorare i suddetti output, non richiedono la registrazione o la programmazione di alcuna macro; si sono infatti privilegiate funzioni di Excel 2010, che hanno consentito comunque di automatizzare e raggruppare i dati necessari.

La funzione conta.se
Ad esempio per realizzare il grafico del trend del personale sì è utilizzata la funzione conta.se al fine di raggruppare il numero di risorse umane presenti in azienda per ciascun anno:
=CONTA.SE(Database!$C$3:$C$98;”<“&A3)= 6, e così via per le righe successive.

 

Il raggruppamento dei dati per dipartimento è stato eseguito mediante l’utilizzo della funzione somma.se:
=SOMMA.SE(Database!$B$3:$B$98;$A17;Database!D$3:D$98)
Il numero di risorse umane per Dipartimento è stato ottenuto attraverso una funzione composta costituita da conta se e una funzione di concatenamento tramite la &:
=CONTA.SE(Database!$B$3:$B$98;”=”&A17)

A questo punto il nostro dashboard con i dati statistici che ci occorrono è in pratica già pronto; grazie a Excel 2010, la grafica e le soluzioni a disposizione sono decisamente arricchite rispetto alle precedenti versioni e ci si può davvero sbizzarrire.

Qui di seguito è riportato uno screenshot esemplificativo e che ritrovate nel file allegato Dashboard excel per le risorse umane:

 

dashboard excel per l'analisi delle risorse umane

I grafici utilizzati nel “dashboard Risorse Umane”

Come potete constatare il suddetto dashboard esemplificativo è costituito da un serie di grafici:

•    Istogramma (crescita personale – Year over Year)

•    Grafico a Torta (% personale per dipartimento)

•    Grafico a Barre (numero persone per dipartimento)

•    Grafico ad Area (Distribuzione salariale)

La sezione dinamica del cruscotto

Come potete notare, nel cruscotto, nella parte in alto a destra, è stata poi creata un’area dinamica denominata Scheda del Dipendente: si seleziona il nome del dipendente e in automatico sono riportate le informazioni di quello specifico dipendente.

 

La funzione indice confronta di excel

La scheda del dipendente recupera i dati attraverso la funzione composta denominata Indice Confronta:

La funzione Indice può essere rappresentata dalla sintassi indicata qui di seguito:

=INDICE(matrice; riga; colonna)

La funzione Confronta cerca un dato in un range di valori e restituisce la relativa posizione (il numero della riga).
Qui di seguito un esempio esteso della funzione utilizzata nella cella O13

=INDICE(Database!$A$3:$I$98;CONFRONTA(Dashboard!$K$9;Database!$A$3:$A$98;0);3)
Simili dashboard sono comodamente personalizzabili e a ogni specifica esigenza e realtà aziendale. L’importante è avere ben chiare le idee e i dati statistici da rappresentare; poi un pizzico di creatività, una linearità nella costruzione del modello e lo sfruttamento delle potenzialità di Excel 2010 ti permetteranno di costruire il tuo dashboard dinamico con estrema semplicità.

 

Scarica il modello dashboard excel per l’analisi delle Risorse umane

Per scaricare il modello Dashboard excel per l’analisi delle risorse umane fai clic qui

Se ti interessano altri modelli excel per il tuo business fai clic qui