Quando si ha a che fare con tabelle dati, spesso si ha la necessità di dover aggregare dati e importi al verificarsi di determinati criteri. La funzione somma se  excel possono essere molto prezioso. In che modo? Vediamolo insieme nel seguente articolo.

 

Somma se excel : sommiamo un cluster di valore in base a determinati da uno o più criteri

Chi utilizza excel è conscio che uno stesso risultato può essere ottenuto percorrendo o adottando strada diverse. Ad esempio il medesimo risultato che posso ottenere utilizzando le formule somma se o somma più se, potrei ottenerlo anche attraverso l’utilizzo di altre funzionalità excel: tabelle pivot, sabotatali, ecc.

Personalmente troviamo molto utili le tabelle pivot nel caso in cui si debba lavorare su file complessi che presentano diversi file tra loro collegati e che richiedono in certe situazioni la restituzione di somme parziali.

Funzione SOMMA.SE: come utilizzarla

La sintassi della funzione Somma se si presenta con la seguente forma:

=SOMMA.SE(intervallo;criterio;[int_somma])

dove:
intervallo
: rappresenta il range o l’intervallo excel dove andare a cercare i valori.
criterio
: rappresenta la nostra condizione che andiamo da ricercare nel nostro intervallo al fine di farci restituire una sommatoria di valori. IL criterio può essere espressione di un testo o anche il risultato derivante dall’applicazione di richiami a valori contenuti in celle o mediante l’utilizzo di formule logiche o caratteri particolari 
Int_somma
: E’ l’intervallo che stabilisce dove devono essere prese le celle da sommare al verificarsi del criterio o della condizione che abbiamo impostato. Definisce le celle che verranno sommate se si realizza il vero della condizione definita nel criterio. Qualora l’argomento venisse omesso verranno calcolate i valori presenti nella colonna sulla quale è stato definito il criterio.

Esempio di utilizzo somma se

Di seguito, proponiamo un semplice esempio di utilizzo.

Supponiamo di avere una base dati, che contiene una serie di prodotti con le vendite, gli agenti di vendita e il mese in cui è avvenuta la vendita:

Supponiamo ora di voler sommare il totale di quanto è stato venduto per il prodotto Pippo:

somma se excel

Come potete vede abbiamo proceduto a:

– selezionare l’intervallo della base dati

– inserire il criterio: Pippo. trattandosi di testo la parola va inserita tra virgolette: “Pippo”

–  indicare l’intervallo dove andare a “pescare” i valori della somma.

Il risultato che si ottiene, sarà pari a 1511.

 

Suggerimento: per rendere più dinamico il calcolo conviene crearsi una tabella di sintesi:

1) Elenchiamo i vari prodotti

2) Nella colonna a costruiamo la formula per ottenere i valori

Come potete vedere, invece di scrivere il nome del prodotto, nella sezione del criterio abbiamo direttamente richiamato la cella dove abbiamo scritto il nome del prodotto:

Asterix —–> cella B51

A questo punto, andando i riferimenti $ di cella su B51, siamo pronti per trascinare la formula:

=SOMMA.SE($B$4:$D$45;$B52;$D$4:$D$45)

Come vedete il $ va inserito solo alla sinestra della cella B51: $B51

Per scaricare il file di esempio sull’utilizzo della funzione somma se excel fare cli qui