Continuiamo a parlare di dashboard aziendali e semplici soluzioni da implementare a supporto di riunioni e creazioni di reporting. In questo articolo proponiamo un semplice esempio di grafico dinamico excel finalizzato a evidenziare i trend mensili di ciascun prodotto.

Utilizzare grafici dinamici excel può rivelarsi molto utile durante una riunione per passare all’analisi di un prodotto all’altro senza appesantire troppo la nostra presentazione o report.

Esempio per creare un grafico dinamico

Nell’esempio, che proponiamo qui di seguito, abbiamo un portafoglio di 4 prodotti e i loro trend di ricavi mensili.

I prodotti in questione sono i seguenti:

Alfa
Beta
Gamma
Delta.

La tabella sotto riporta i ricavi ottenuti:

Per la costruzione del nostro grafico dinamico, creiamo un file excel composto da un foglio input, dove inseriamo la suddetta tabella in modalità trasposta:

 

Come costruire il grafico dinamico excel in tre step

Procediamo ora alla costruzione del grafico nel nostro foglio output, seguendo i seguenti passaggi:

2. utilizziamo la funzione convalida dati per creare un elenco a cascata dei nostri prodotti.

 

 

2. utilizziamo la funzione indice.confronta per creare la formula che ci permetterà di dare dinamicità al grafico:

=INDICE(input!$B$5:$N$9;CONFRONTA(output!$E4;input!$B$5:$B$9;0);1+output!E$8)

Per dare più informazione visuale creiamo anche il trend cumulato mese su mese dei ricavi.

Trasciniamo la suddetta formula sui vari mesi in modo da ottenere un risultato di questo tipo:

 

 

3 costruiamo il grafico excel utilizzando la tabella che abbiamo appena costruito.

Otterremo così il seguente risultato:

Come potete vedere. nel grafico abbiamo sia i ricavi mensili che il trend cumulato con evidenza del valore complessivo venduto al 31-12.

Abbiamo poi inserito il titolo dinamico del grafico che si auto aggiorna al cambio del prodotto selezionato. In pratica nella cella Y2 abbiamo inserito questa formula: =B2&” “&E4, che uniche la stringa “Analisi trend” con il nome del prodotto. A questo punto basta cliccare sul titolo del grafico, mettersi poi nella barra della formula e inserire il collegamento alla cella.

 

 

A questo punto posizioniamo il grafico sopra la tabella delle formule e utilizziamo select data per scegliere il prodotto di cui si vuole visualizzare il trend:

 

 

Per scaricare il file di esempio excel puoi procedere facendo clic qui

Risorse per approfondire

Strumenti e guide excel per il tuo business

Modelli excel da scaricare per l’attività quotidiana

Alcune best practices per la costruzione di dashboard