La funzione somma.se excel e somma.più.se excel sono molto utili nella costruzione di output di sintesi per estrapolare sommatorie di dati e aggregazioni di dati, che soddisfano a determinati criteri. I campi di applicazioni possono essere numerosi e con estrema semplicità consentono di rendere più dinamico e automatico il processo di analisi e di ricerca.

La funzione permette ad esempio all’interno di un database delle vendite di sommare solo le vendite relative ad un ipotetico prodotto Pippo, le cui righe sono posiizonate in puinti differenze dell’elenco. Un altro esempio di utilizzo è quello di sommare solo gli importi che sono superiori ad una determinata cifra; oppure ancora per sommare le vendite di una specifico giorno, settimana o mese.

 

Peculiarità della funzione somma.se

La funzione SOMMA.SE Excel consente di definire un criterio ottenendo la somma solo le celle il cui valore soddisfa la condizione assegnata

La sintassi della formula è molto semplice:

=Somma.se(Intervallo;criterio;intervallo somma)

 

Se ad esempio vogliamo sapere la somma delle vendite del prodotto Pippo procederemo  a scrivere la formula nel seguente modo:

La funzione è stata scritta in questo modo:
=SOMMA.SE(B2:B100;”Pippo”;C2:C100)
La fomula si legge nel seguente modo: vadi a cercarmi nell’intervallo B2:B100 tutte quelle celle che contengono la parola Pippo e resistuiscimi poi la somma utilizzando la i dati correlati della colonna C.

 

Funzione somma.più.se.: per soluzioni avanzate

Nel caso in cui dovete soddisfare più criteri contemporaneamente potete sfruttare la funzione somma.più.se

La sintassi della somma.più.se è simile alla somma.se con l’aggiunta di criteri multipli:
SOMMA.PIÙ.SE(intervallo_somma; Criterio_intervallo1; Criterio1 [; Criterio_intervallo2; Criterio2 [; …]])

Dove:

intervallo_somma rappresneta  il parametro obbligatorio costituito da:

– un intervallo di celle,

– nome di un’area indicata,

– intestazione di colonna o di riga che contiene valori che vanno restituiti come somma.

Criterio_intervallo1 – è un altro parametro obbligatorio, ed è rappresentato da un intervallo di celle, un’area di celle definita con un nome, l’intestazione di colonna o di riga che contiene valori per trovare il criterio corrispondente.

Criterio1  è un altro argomento obbligatorio. E’ un ulteriore criterio di ricerca e può contenere testo, numeri, espressioni regolari o caratteri jolly (se abilitati nelle opzioni di calcolo).

Criterio_intervallo2  è opzionale opzionale.

Criterio2  è opzionale.

Esempi di applicazione della funzione somma.più.se

Come già evidenziato la funzione somma.se può tornare utile in diversi ambiti applicativi.

Supponiamo di avere un database delle vendite costituito da diverse colonne, come ad esempio:

  • anno fiscale
  • prodotto
  • area geografica
  • fatturato

somma.più.se

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Se dobbiamo semplicemente estrpoalare le vendite “Pippo”, nel FY2017 utilizzeremo la formula nel seguente modo:

=SOMMA.PIÙ.SE(R4:R33;O4:O33;U4;P4:P33;V4)

Se invece volgiamo sommare tutte le vendite Pippo del Fy 2017 con importo superiore (>) a 30.000 euro utilizzeremo la seguente:

=SOMMA.PIÙ.SE(R4:R33;O4:O33;U5;P4:P33;V5;R4:R33;”>=”&W5)

Come potete vedere in un criterio abbiamo utilizzato il carattere “>” concatenato “&” con 30.000 euro (cella w5)

Un altro esempio potrebbe essere il seguente:

=SOMMA.PIÙ.SE(R4:R33;O4:O33;U6;P4:P33;V6;Q4:Q33;”*”&W6)

Dove andiamo ad individuare le sole vendite del nord est. Utlizzando il carattere Jolly (*) per estrapolare come criterio “est”, dato che Nord può essere anche Ovest.

 

Di seguito il riepilogo dei risultati:

 

 

 

Se invece desideriamo sapere le vendite che soddisfano i criteri: FY 2017, PAPERINO, PLUTO, utilizzeremo la seguente formula:

=SOMMA.PIÙ.SE(R4:R33;O4:O33;U15;P4:P33;V15)+SOMMA.PIÙ.SE(R4:R33;O4:O33;U15;P4:P33;W15)

 

Download file excel di esempio

Come vede i campi di applicazione pososno essere molti.

Per scaricare il file di esempio applicativo della funzione somma.più.se, fai clic qui

 

Altri esempi di utilizzo

Analisi della rete di vendita con la funzione somma.se

Creare un dashboard per le risorse umane

Dai un’occhiata anche all’articolo evergreen 40 modelli excel per il tuo business

Video di spiegaizone sulla funzione somma.più.se

 

Ebook da leggere su excel

Se vuoi approfondire le tematiche di excel con ambito pratico e applicativo aziendale, ti suggeriamo di visitare il nostro eshop dove troverai diversi ebook tematici in excel.