Funzione grande e piccolo excel. Spesso nella costruzione di dashboard o cruscotti aziendali, può essere necessario riepilogare delle classifiche. Ad esempio i 5 migliori o peggiori clienti per fatturato. Scopo di questo articolo è quello di esaminare il funzionamento delle funzioni grande e piccolo excel per risolvere in maniera automatica queste situazioni.

Funzione grande e piccolo excel: a cosa servono? Partiamo dalla funzione GRANDE.

 

La funzione Grande di excel

Questa funzione in pratica Restituisce il k-esimo valore più grande di un set di dati. Ad esempio è possibile utilizzare la funzione GRANDE per selezionare un valore in base alla sua posizione relativa, per restituire il risultato e classificarlo per posizioni. alla prima.

La sintassi della funzione grande è la seguente:

GRANDE(matrice; k)

dove,

per Matrice si fa riferimento a un intervallo di dati, di cui si vuole individuare il k-esimo valore più grande.

per s’intende la posizione, partendo dal valore più grande, nella matrice o nell’intervallo di celle dei dati da restituire.

 

La funzione Piccolo di excel

La funzione piccolo, come potrete immaginare opera in maniera inversa alla funzione grande. In pratica, restituisce il k-esimo valore più piccolo di un set di dati. In genere viene applicata per  restituire i valori con una particolare condizione relativa in un set di dati.

La sintassi della funzione piccolo è la seguente:

PICCOLO(matrice; k)

dove,

per Matrice si indente la Matrice o l’intervallo di dati numerici di cui si desidera determinare il k-esimo valore più piccolo.

per K  si fa riferiemnto alla posizione del valore da restituire, partendo dal più piccolo, nella matrice o nell’intervallo.

 

Esempio di applicazione

Supponiamo di avere un database di clienti e il relativo fatturato e di voler estrapolare i 5 migliori e i 5 peggiori generatori di ricavo utilizzando la funzione grande e piccolo excel.

funzione grande e piccolo excel

Per calcolare i migliori 5 fatturati, dovremo utilizzare la seguente formula:

=GRANDE($B$5:$B$14;F6)

L’intervallo B5:B14 rappresenta l’intervallo dati del fatturato, F6 la cella che contiene il numero progressivo.

Il risultato che otterremo sarà il seguente:

Analogamente per estrapolare i 5 peggiori fatturati ci muoveremo con la stessa modalità applicando la funzione piccolo excel:

PICCOLO($B$5:$B$14;J5)

Fuznione grande e piccolo excel

 

Come potete notare l’applicazione delle due formule è piuttosto semplice. Nell’esempio è molto semplice; questa applicazione può avere il limite dovuto alla situazione in cui abbiamo clienti con il medesimo fatturato. In questo caso occorrerà associare ogni singolo fatturato ad un valore unitario identificativo ad esempio utilizzando formule del seguente tipo:

B5+(CONTA.SE($B$5:B5;B5)-1)*0,0000001

La funzione excel dovrà poi essere combinata con la funzione righe indice confronta aiuterà ad ovviare il problema.

Il calcolo del numero univoco può essere fatto nel seguente modo

GRANDE($B$21:$B$30;RIGHE($B$21:B21)) e si trascina la formula.

La fomrula successiva sarà:

=INDICE($B$21:$B$30;CONFRONTA(GRANDE($C$21:$C$30;RIGHE($C$21:C22));$C$21:$C$30;0))

In questo modo vi riconoscerà e classificherà un medesimo valore come nell’esempio sotto dove abbiamo 2 clienti con 20.000.

Il nome del cliente associato lo calcoleremo utilizzando la seguente formula:

=INDICE($A$21:$A$30;CONFRONTA(GRANDE($C$21:$C$30;RIGHE($C$21:C21));$C$21:$C$30;0)):

 

 

Download esempio Funzione grande e piccolo excel

Per scaricare gratuitamente il file dell’esempio fai clic qui

 

Risorse per approfondire

Se ti interessano altri esempi o modelli excel leggi anche i seguenti articoli:

40 modelli gratuiti excel per il tuo business

ebook pratici su excel applicati in ambito aziendale

Funzione somma.se e somma.più.se

Grafici e tabelle excel per l’analisi delle vendite