Come usare le matrici in excel. Quale approccio seguire per rendere più dinamici i vostri modelli. Tecniche e soluzioni ed esempi pratici.

In questo articolo viene preso in esame il concetto di matrici e il loro campo di applicazione all’interno del foglio elettronico excel. La matrici più diffusamente conosciuta in lingua inglese con il termine “array” viene comunemente definita come un “insieme di elementi”. Mark Dodge esperto di Microsoft Excel evidenzia 3 principali concetti che si devono conoscere nell’ambito matriciale:

1)    Una formula sviluppata in forma di matrice agisce su 2 o più gruppi di valori (Argomenti della matrice) per restituire uno o più output o risultati finali.

2)    Si definisce intervallo di matrice quel blocco di celle che ha in condivisione una comune formula in forma di matrice

3)    La costante di matrice è rappresentata da un elenco strutturato in modo particolare di valori costanti, che possono essere utilizzati come argomenti nelle formule in forma di matrice.

Per capire meglio le peculiarità di una matrice in excel qui di seguito viene proposto un esempio di matrice  di tipo monodimensionale.

Supponiamo di avere a titolo esemplificativo una tabella che riepiloga le vendite di un certo numero di prodotti per i primi 9 mesi dell’anno e di voler calcolare la media.

Ci possiamo muovere sfruttando la funzione media oppure sommare tutte le vendite dei vari mesi e dividere il risultato per 9. La formula inizialmente inserita nella cella M7 sarà poi trascinata nelle celle sottostanti fino a M13.

Pertanto il risultato media del prodotto A sarà dato dalle seguenti formule:

=MEDIA(D7:L7)

Oppure da:

=SOMMA(D7:L7)/9 dove 9 rappresenta il numero di mesi

Il risultato sarà identico e sarà pari a 26,88

La fomula a matrice in tre step

L’alternativa può essere quella di usare una singola formula collocata in forma di matrice.
La procedura è la seguente:

1)    Selezionare l’intervallo M7:M13

2)    Digitare la formula =(D7:D13+E7:E13+F7:F13+G7:G13+H7:H13+I7:I13+J7:J13+K7:K13+L7:L13)/9 nella barra della formula

3)    Premere CTRL + MAIUSC + INVIO

Facendo in questo modo la formula sarà utilizzata in forma di matrice e sarà collocata automaticamente in tutte le celle selezionate creando 7 formule diverse in M7, M8, M9, M10, M11, M12, M13.

Le regole delle Matrici

Ricorda la formula matriciale è riconoscibile dal fatto che la formula evidenziata nella barra della formula sarà racchiusa nelle parentesi graffe.

Mark Dodge, nel suo libro “Excel oltre ogni limite”, evidenzia poi alcune regole da seguire per le formule in forma di matrice:

a)    Premere CTRL + INVIO + MAIUSC per bloccare una formula in forma di matrice. IN questo modo excel posizionerà le parentesi graffe per racchiudere la formula. Le formule graffe non vanno digitate in modalità manuale,  perché  excel le interpreterà come testo e la funzione matrice non funzionerà.

b)    Non è possibile modificare, cancellare o spostare celle presenti in un intervallo di matrice, né aggiungere o togliere celle. Ricorda la definizione di matrice come insieme di elementi.

c)    Per modificare una matrice occorre selezionarla per intero, poi fare clic sulla barra della formula, apportare le modifiche e infine premere nuovamente CTRL + INVIO + MAIUSC per bloccare la formula

d)    La matrice può essere cancella selezionandola per intero e poi premendo CANC

e)    E’ possibile selezionare una matrice con le scorciatoie dei tasti rapidi: selezionare la matrice e poi premere CTRIL + MAIUSC +/

f)    Se desideri spostare una matrice occorre sempre evidenziarla tutta.

RISORSE PER APPROFONDIRE

Se desideri apprendere trucchi e suggeirmenti su excel con un approccio pratico e intuitivo suggeriamo la lettura dei seguenti ebook:

Applicazioni aziendali in excel

Modelli economico fnanziari in excel

Applicazioni pratiche con le tabelle pivot

 

Excel e il calcolo tabellare volume 1 – nozioni fondamentali

 

Excel avanzato Massimo Zucchini

 

Excel e il calcolo tabellare volume 2 – Matrici e formule matriciali

copertina_calcolo_tabellare_volume2